Selasa, 19 Mei 2015

[smf_addin] Digest Number 3410

5 Messages

Digest #3410
1a
Ycharts by gobi5
2a
2b
Re: Ycharts problem by "Randy Harmelink" rharmelink
3b
Re: financial times extraction by "Randy Harmelink" rharmelink

Messages

Mon May 18, 2015 11:24 am (PDT) . Posted by:

gobi5

I have been using RCHGetTableCell to pull data from Ycharts for a while now. Over the weekend, Ycharts was down for maintenance and when it came back up, I can no longer get the data. It doesn't look to me like the design of the pages has changed, so I'm not sure what's going on.


Here are some examples of what I'm using:


=(RCHGetTableCell("http://ycharts.com/companies/"&A3&"/dividend_yield",1,"Dividend Yield (TTM) Range, Past 5 Years","Average"))





=(RCHGetTableCell("http://ycharts.com/companies/"&A6&"/ps_ratio",1,"PS Ratio (TTM) Range, Past 5 Years","Average"))



Any ideas?


Mon May 18, 2015 11:26 am (PDT) . Posted by:

gobi5

I have been using RCHGetTableCell to pull data from Ycharts for a while now. Over the weekend, Ycharts was down for maintenance and when it came back up, I can no longer get the data. It doesn't look to me like the design of the pages has changed, so I'm not sure what's going on.


Here are some examples of what I'm using:


=(RCHGetTableCell("http://ycharts.com/companies/"&A3&"/dividend_yield",1,"Dividend Yield (TTM) Range, Past 5 Years","Average"))





=(RCHGetTableCell("http://ycharts.com/companies/"&A6&"/ps_ratio",1,"PS Ratio (TTM) Range, Past 5 Years","Average"))




Any ideas?


Mon May 18, 2015 2:02 pm (PDT) . Posted by:

"Randy Harmelink" rharmelink

No ideas here. I copied and pasted your two formulas and both worked fine
for me.

Grasping at straws -- you may have some cached web pages from the weekend.
Make sure your Internet Options are set to always get a fresh copy of a web
page. And exit and restart EXCEL (or run the smfForceRecalculation macro)
so that the add-in retrieves a fresh copy of the web page as well.

On Mon, May 18, 2015 at 11:26 AM, cmaxmagee@gmail.com [smf_addin] <
smf_addin@yahoogroups.com> wrote:

>
> I have been using RCHGetTableCell to pull data from Ycharts for a while
> now. Over the weekend, Ycharts was down for maintenance and when it came
> back up, I can no longer get the data. It doesn't look to me like the
> design of the pages has changed, so I'm not sure what's going on.
>
>
> Here are some examples of what I'm using:
>
>
> =(RCHGetTableCell("http://ycharts.com/companies/"&A3&"/dividend_yield",1,"Dividend
> Yield (TTM) Range, Past 5 Years","Average"))
>
>
> =(RCHGetTableCell("http://ycharts.com/companies/"&A6&"/ps_ratio",1,"PS
> Ratio (TTM) Range, Past 5 Years","Average&quot;))
>
> Any ideas?
>

Mon May 18, 2015 11:34 am (PDT) . Posted by:

grizzzzzzly

Appreciate the reply Randy, thank you.


Array entered RCHGetHTMLTable() function over a range matching the table with the 6 month price change data but still receiving a blank cell result i.e all range cells are showing blank. Addin is working fine - I'm getting the expected results with RCHGetYahooQuotes and RCHGetYahooHistory queries - but still at a loss as to why my RCHGetHTMLTable on the FT website isn't returning anything. Any further thoughts/advice much appreciated.

Mon May 18, 2015 2:35 pm (PDT) . Posted by:

"Randy Harmelink" rharmelink

Not sure what to tell you. If I array-enter this over a range:

=RCHGetHTMLTable("
http://markets.ft.com/research/Markets/Tearsheets/Summary?s=GOOG:NSQ","Past
90 Days",1,"",1)

...I get:

1 week 1 month 6 months 1 year 5 years Google Inc -0.0063 0.0185 -0.0195
0.0252 0 S&P 500 INDEX 0.0083 0.02 0.0406 0.1304 0.8939 USA/INFORMATION
TECH 0.0122 0.0389 0.049 0.1752 0.5075 USA/INTERNET SOFT & SVC 0.0078
0.0008 0.0157 0.1319 0.5992

On Mon, May 18, 2015 at 11:34 AM, grizzzzzzly@yahoo.com [smf_addin] <
smf_addin@yahoogroups.com> wrote:

>
> Appreciate the reply Randy, thank you.
>
> Array entered RCHGetHTMLTable() function over a range matching the table
> with the 6 month price change data but still receiving a blank cell result
> i.e all range cells are showing blank. Addin is working fine - I'm getting
> the expected results with RCHGetYahooQuotes and RCHGetYahooHistory queries
> - but still at a loss as to why my RCHGetHTMLTable on the FT website
> isn't returning anything. Any further thoughts/advice much appreciated.
>
>
For the Add-in, Documentation, Templates, Tips and FAQs, visit http://ogres-crypt.com/SMF

Tidak ada komentar:

Poskan Komentar