Sabtu, 06 Desember 2014

[smf_addin] Digest Number 3259

14 Messages

Digest #3259
1b
Re: Having some problem, just started. by "Randy Harmelink" rharmelink
1d
Re: Having some problem, just started. by "Randy Harmelink" rharmelink
2b
Re: Upgrade from Excel 2010 to Excel 2013 by "Randy Harmelink" rharmelink
2d
Re: Upgrade from Excel 2010 to Excel 2013 by "Randy Harmelink" rharmelink
2e
3a
Google web scraper by indinvestor111
3b
Re: Google web scraper by "Randy Harmelink" rharmelink

Messages

Fri Dec 5, 2014 2:59 am (PST) . Posted by:

smurfekidsa

Have confirmed to addin works with the "get element version code"
but when I write a code in the function excel always return me with the message that "we found a problem with this formula"

What am I doing wrong?


Fri Dec 5, 2014 3:03 am (PST) . Posted by:

"Randy Harmelink" rharmelink

That an EXCEL error message, telling you you're not constructing the
formula correctly. I looked up the message on Google, and found:

http://support.microsoft.com/kb/2853427

On Fri, Dec 5, 2014 at 3:35 AM, pepperkaker@... wrote:

>
> Have confirmed to addin works with the "get element version code"
> but when I write a code in the function excel always return me with the
> message that "we found a problem with this formula"
>
> What am I doing wrong?
>

Fri Dec 5, 2014 3:30 am (PST) . Posted by:

smurfekidsa

I made sure that "The list separator in Window" is the same one as I use in excel ";" and that "use system settings is enabled" So now I dont get the excel error message anymore. But I still get the message "error" in the field I write the code. I have tried many from the list with the codes.

Fri Dec 5, 2014 6:58 am (PST) . Posted by:

"Randy Harmelink" rharmelink

Without an example, I have nothing to go on as to what the error might be
caused by. You don't even mention which function you are using. A recent
development -- all MSN elements for the RCHGetElementNumber() function are
now obsolete, as MSN revamped their website recently and no longer has the
data. If trying AdvFN elements, check out the items on the "Tips and FAQs"
web page.

On Fri, Dec 5, 2014 at 4:30 AM, pepperkaker@... wrote:

>
> I made sure that "The list separator in Window" is the same one as I use
> in excel ";" and that "use system settings is enabled" So now I dont get
> the excel error message anymore. But I still get the message "error" in the
> field I write the code. I have tried many from the list with the codes.
>

Fri Dec 5, 2014 5:23 am (PST) . Posted by:

whelchelej

Randy,

I have used the RCH Stock Market Functions add in for years. I just upgraded to Excel 2013. When I now open an Excel file by double clicking on it or from the Start key Excel recents panel, Excel opens and the tool bars populate, but where the spreadsheet should appear there's nothing but a blank white screen. This never happened with Excel 2010, 2007 or 2003. I have searched other posts on this forum and see no references to this problem. I have tried the 2 or 3 fixes for this white screen problem I see online in forums dealing with Office problems generally, and none work. I reinstalled Office yesterday and still have the same problem. I also spent about an hour on the telephone with Microsoft yesterday. The problem disappears when the add-in is unchecked through the manage add-ins box in Excel, so Microsoft says, not our problem, but the instead is the third party software provider's problem, even though there's clearly been a loss of functionality between Excel 2010 and 2013.

Are you aware of any fix for this problem on your end? I would very much appreciate any thoughts you might have.

Thanks very much for your help.


Fri Dec 5, 2014 8:09 am (PST) . Posted by:

"Randy Harmelink" rharmelink

I'm still using EXCEL 2007, so I have no experience with EXCEL 2013. But I
believe there are other EXCEL 2013 users that are using the add-in...

Which version of the add-in are you using? Are you using any other add-ins?

On Fri, Dec 5, 2014 at 6:23 AM, JWhelchel@... wrote:

>
> I have used the RCH Stock Market Functions add in for years. I just
> upgraded to Excel 2013. When I now open an Excel file by double clicking
> on it or from the Start key Excel recents panel, Excel opens and the tool
> bars populate, but where the spreadsheet should appear there's nothing but
> a blank white screen. This never happened with Excel 2010, 2007 or 2003.
> I have searched other posts on this forum and see no references to this
> problem. I have tried the 2 or 3 fixes for this white screen problem I see
> online in forums dealing with Office problems generally, and none work. I
> reinstalled Office yesterday and still have the same problem. I also spent
> about an hour on the telephone with Microsoft yesterday. The problem
> disappears when the add-in is unchecked through the manage add-ins box in
> Excel, so Microsoft says, not our problem, but the instead is the third
> party software provider's problem, even though there's clearly been a loss
> of functionality between Excel 2010 and 2013.
>
> Are you aware of any fix for this problem on your end? I would very much
> appreciate any thoughts you might have.
>
>

Fri Dec 5, 2014 11:08 am (PST) . Posted by:

whelchelej

I am using 2.1.2014.01.30, which is the latest version, I believe. I am using two other add-ins, both COM add ins, one for Dragon Dictate Naturally Speaking and one for Send to Bluetooth, the latter appears to be Intel related.

Fri Dec 5, 2014 11:40 am (PST) . Posted by:

"Randy Harmelink" rharmelink

Sorry, but I haven't a clue as to what might be going on.

Have you tried one of the "Lite" versions of specific add-in functions from
the Yahoo group files area?

Can you deactivate the add-in, then open up a workbook that uses its
functions, and THEN activate the add-in?

Or, can you open a new workbook with the add-in deactivated, then activate
the add-in, and THEN use add-in functions?

On Fri, Dec 5, 2014 at 12:08 PM, JWhelchel@comcast.net [smf_addin] <
smf_addin@yahoogroups.com> wrote:

>
> I am using 2.1.2014.01.30, which is the latest version, I believe. I am
> using two other add-ins, both COM add ins, one for Dragon Dictate Naturally
> Speaking and one for Send to Bluetooth, the latter appears to be Intel
> related.
>

Fri Dec 5, 2014 1:45 pm (PST) . Posted by:

"Brad Reel" reeldeal9090

I use with Excel 2013 on one computer and Excel 2010 on another. Never
experienced the problem you are encountering. Just to be clear, are you
able to open a new file and it open fine? Can you do this with both the
Add-in activated and not activated?

On Fri, Dec 5, 2014 at 1:08 PM, JWhelchel@comcast.net [smf_addin] <
smf_addin@yahoogroups.com> wrote:

>
>
> I am using 2.1.2014.01.30, which is the latest version, I believe. I am
> using two other add-ins, both COM add ins, one for Dragon Dictate Naturally
> Speaking and one for Send to Bluetooth, the latter appears to be Intel
> related.
>
>

Fri Dec 5, 2014 1:15 pm (PST) . Posted by:

indinvestor111

Hi Randy,


Do you know if installing the Google web scraper would adversely affect the add_in?


Thanks

Fri Dec 5, 2014 3:36 pm (PST) . Posted by:

"Randy Harmelink" rharmelink

The Google Web Scraper is an extension for the Chrome browser, right? If
so, it shouldn't affect EXCEL and the add-in at all.

Well, except for web sites like IBD that only allow you to be logged in
from a single browser. If you scraped something in Chrome, it would nullify
your IE security cookie. You'd need to recreate that cookie if you wanted
EXCEL and the add-in to get data from the IBD web pages again. I used to
have that problem -- I couldn't go back and forth between FireFox and
EXCEL/add-in. Each time I switched, I would have to log into that browser
entity again.

On Fri, Dec 5, 2014 at 2:15 PM, elandry@... wrote:

>
> Do you know if installing the Google web scraper would adversely affect
> the add_in?
>

Fri Dec 5, 2014 1:18 pm (PST) . Posted by:

weldenc

I am using a variation on the file SMF-Template-RCHGetYahooQuotes.xls http://ogres-crypt.com/SMF/Templates/SMF-Template-RCHGetYahooQuotes.xls. It works great in Excel 2007. I recently updated to Office 365 which is basically Excel 2013. I had problems since. Sometimes my spreadsheet opens fine. At other times I get the ###### problem.


Today it stopped working altogether. When I go to add-ins it says RCH_Stock_Market_Functions is Unknown


I downloaded the newest version of SMF-Template-RCHGetYahooQuotes.xls http://ogres-crypt.com/SMF/Templates/SMF-Template-RCHGetYahooQuotes.xls. (RCH_Stock_Market_Functions-2.1.2014.01.30) and installed. It had no effect. I also downloaded a virgin copy of SMF-Template-RCHGetYahooQuotes.xls http://ogres-crypt.com/SMF/Templates/SMF-Template-RCHGetYahooQuotes.xls.


In Excel 2007 when I click on an element in the newly downloaded virgin template is see the path is ='E:\SMF Add-in\RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW()). Of course the elements say #######.


When I open up my spreadsheet in 2007 the element path is =RCHGetYahooQuotes(B4:B200,C2:V2,NOW()). It works normally.


If I edit the virgin template and change ='E:\SMF Add-in\RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW()) to ='RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW()), it works fine in Excel 2007


When I open the virgin template in Excel 2013, I get the standard message about updating links to external source that could be unsafe. I click update and get the ###### results.


When I try to edit the range in the template to change the element path as I did above. I cannot seem to change the ='E:\SMF Add-in\RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW()). I don't get an error. It just won't change.


Next I went to edit links and saw the addin was Unknown. When I update the link and go back to the template is see that the element path has changed to ='C:\Program Files\SMF Add-in\RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW()). This correct and where I keep the addin. I still get ######.


If I try to edit ='C:\Program Files\SMF Add-in\RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW()) it will not change


Does anyone have an explanation or fix that will allow me to run either my spreadsheet of the virgin SMF-Template-RCHGetYahooQuotes.xls http://ogres-crypt.com/SMF/Templates/SMF-Template-RCHGetYahooQuotes.xls in Excel 2013? Thanks

Fri Dec 5, 2014 1:40 pm (PST) . Posted by:

"Brad Reel" reeldeal9090

Office 365 is a little bit different that Office 2013. Office 365 is
technically 100% cloud. Even if you are not using the "cloud only"
version, you can't store the file in the cloud and open it from there. You
need to download it and then open it local on your computer. If you don't
download before you open, all the references to the add-in will get jacked
up. There is a macro I believe Randy built that will fix the references -
I've never used it so I can't speak to it. But, even if you fix, if you
store in the cloud, they will get jacked up again. My experience is that
you can store in cloud, download and open and it will work fine, but if you
open in cloud, no joy.

Maybe someone else has had a different experience and can give you
different guidance, but that's the behavior I've seen. I recommend keeping
your working copy local and storing a backup in the cloud.

On Fri, Dec 5, 2014 at 3:18 PM, weldencd@comcast.net [smf_addin] <
smf_addin@yahoogroups.com> wrote:

>
>
> I am using a variation on the file SMF-Template-RCHGetYahooQuotes.xls
> <http://ogres-crypt.com/SMF/Templates/SMF-Template-RCHGetYahooQuotes.xls>.
> It works great in Excel 2007. I recently updated to Office 365 which is
> basically Excel 2013. I had problems since. Sometimes my spreadsheet opens
> fine. At other times I get the ###### problem.
>
>
> Today it stopped working altogether. When I go to add-ins it says
> RCH_Stock_Market_Functions is Unknown
>
>
> I downloaded the newest version of SMF-Template-RCHGetYahooQuotes.xls
> <http://ogres-crypt.com/SMF/Templates/SMF-Template-RCHGetYahooQuotes.xls>.
> (RCH_Stock_Market_Functions-2.1.2014.01.30) and installed. It had no
> effect. I also downloaded a virgin copy of
> SMF-Template-RCHGetYahooQuotes.xls
> <http://ogres-crypt.com/SMF/Templates/SMF-Template-RCHGetYahooQuotes.xls>.
>
>
> In Excel 2007 when I click on an element in the newly downloaded virgin
> template is see the path is ='E:\SMF
> Add-in\RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW()).
> Of course the elements say #######.
>
>
> When I open up my spreadsheet in 2007 the element path is
> =RCHGetYahooQuotes(B4:B200,C2:V2,NOW()). It works normally.
>
>
> If I edit the virgin template and change ='E:\SMF
> Add-in\RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW())
> to
> ='RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW()),
> it works fine in Excel 2007
>
>
> When I open the virgin template in Excel 2013, I get the standard message
> about updating links to external source that could be unsafe. I click
> update and get the ###### results.
>
>
> When I try to edit the range in the template to change the element path as
> I did above. I cannot seem to change the ='E:\SMF
> Add-in\RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW()).
> I don't get an error. It just won't change.
>
>
> Next I went to edit links and saw the addin was Unknown. When I update the
> link and go back to the template is see that the element path has changed
> to ='C:\Program Files\SMF
> Add-in\RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW()).
> This correct and where I keep the addin. I still get ######.
>
>
> If I try to edit ='C:\Program Files\SMF
> Add-in\RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW())
> it will not change
>
>
> Does anyone have an explanation or fix that will allow me to run either my
> spreadsheet of the virgin SMF-Template-RCHGetYahooQuotes.xls
> <http://ogres-crypt.com/SMF/Templates/SMF-Template-RCHGetYahooQuotes.xls> in
> Excel 2013? Thanks
>
>
>

Fri Dec 5, 2014 3:41 pm (PST) . Posted by:

"Randy Harmelink" rharmelink

Whenever you have a path like that in front of the function name, you have
a location error. When EXCEL should have warned you that you had unresolved
links, you should NOT use the "Edit Links" choice it gives you. I've found
that to be unreliable in fixing the problem.

However, you should just be able to run the smfFixLinks macro. It just does
a "Find and Replace All" and removes all of those path prefixes on your
formulas. I used to suggest that be done manually, but the macro should be
the refined extension of that process.

See the location errors item on the "Tips and FAQs" web page for more info.

On Fri, Dec 5, 2014 at 2:18 PM, weldencd@comcast.net [smf_addin] <
smf_addin@yahoogroups.com> wrote:

> I am using a variation on the file SMF-Template-RCHGetYahooQuotes.xls
> <http://ogres-crypt.com/SMF/Templates/SMF-Template-RCHGetYahooQuotes.xls>.
> It works great in Excel 2007. I recently updated to Office 365 which is
> basically Excel 2013. I had problems since. Sometimes my spreadsheet opens
> fine. At other times I get the ###### problem.
>
> Today it stopped working altogether. When I go to add-ins it says
> RCH_Stock_Market_Functions is Unknown
>
> I downloaded the newest version of SMF-Template-RCHGetYahooQuotes.xls
> <http://ogres-crypt.com/SMF/Templates/SMF-Template-RCHGetYahooQuotes.xls>.
> (RCH_Stock_Market_Functions-2.1.2014.01.30) and installed. It had no
> effect. I also downloaded a virgin copy of
> SMF-Template-RCHGetYahooQuotes.xls
> <http://ogres-crypt.com/SMF/Templates/SMF-Template-RCHGetYahooQuotes.xls>.
>
> In Excel 2007 when I click on an element in the newly downloaded virgin
> template is see the path is ='E:\SMF
> Add-in\RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW()).
> Of course the elements say #######.
>
> When I open up my spreadsheet in 2007 the element path is
> =RCHGetYahooQuotes(B4:B200,C2:V2,NOW()). It works normally.
>
> If I edit the virgin template and change ='E:\SMF
> Add-in\RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW())
> to
> ='RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW()),
> it works fine in Excel 2007
>
> When I open the virgin template in Excel 2013, I get the standard message
> about updating links to external source that could be unsafe. I click
> update and get the ###### results.
>
> When I try to edit the range in the template to change the element path as
> I did above. I cannot seem to change the ='E:\SMF
> Add-in\RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW()).
> I don't get an error. It just won't change.
>
> Next I went to edit links and saw the addin was Unknown. When I update the
> link and go back to the template is see that the element path has changed
> to ='C:\Program Files\SMF
> Add-in\RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW()).
> This correct and where I keep the addin. I still get ######.
>
> If I try to edit ='C:\Program Files\SMF
> Add-in\RCH_Stock_Market_Functions.xla'!RCHGetYahooQuotes(B4:B203,C2:V2,,NOW())
> it will not change
>
> Does anyone have an explanation or fix that will allow me to run either my
> spreadsheet of the virgin SMF-Template-RCHGetYahooQuotes.xls
> <http://ogres-crypt.com/SMF/Templates/SMF-Template-RCHGetYahooQuotes.xls> in
> Excel 2013? Thanks
>
For the Add-in, Documentation, Templates, Tips and FAQs, visit http://ogres-crypt.com/SMF

Tidak ada komentar:

Poskan Komentar